Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

13.592 18
 #1
Escrito   0  0  
Hola,

Esto sirve para, por ejemplo, poder ejecutar en un iPhone versión 2.0 (o inferior) una aplicación que necesite la versión 2.2.1 (o superior en el futuro).

Necesitaremos WinRar, aunque supongo que podrá hacerse con otros programas similares.

1º) Localizamos la aplicación (.ipa) que queremos modificar (usando por ejemplo el buscador, o directamente dentro de la carpeta de iTunes), y nos aseguramos de que el archivo se puede modificar: hacemos 'click' con botón derecho--> Propiedades y nos aseguraremos de que la casilla 'Sólo lectura' NO esté marcada. Si lo está, le quitamos la marca y le damos a 'Aplicar' y 'Aceptar'.

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente


2º) Ahora, sobre el mismo archivo '.ipa', hacemos 'click' con botón derecho--> Abrir con--> WinRar

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

3º) Hacemos doble 'click' en la carpeta 'Payload'

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

4º) Dentro de la carpeta 'Payload' hay otra carpeta con el nombre de la aplicación y la extensión '.app'. Hacemos doble 'click' sobre ella.

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

5º) Dentro de de esta carpeta, buscamos el fichero "info.plist" y lo arrastramos, por ejemplo, al escritorio para poder trabajar con el.
La ventana de WinRar la minimizamos para usarla de nuevo al final del proceso.

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

6º) Hacemos 'click' con el botón derecho sobre el fichero "info.plist" que hemos arrastrado, y seleccionamos Abrir con--> WorPad.

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente


Tratos OK: deltaone, jahj, Volandius, bigganda, celit, warinice, pluvio, m3406vy, toyoti143


TUTORIAL: Cómo ejecutar en el iPhone aplicaciones que requieren un software más actualizado.
 #2
Escrito   0  0  
7º) Se nos abrirá un cuadro de texto y localizaremos, casi al final del mismo "<key>MinimumOSVersion</key> <string>2.2.1</string>" (en este caso, la aplicación requiere una versión 2.2.1).

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

8º) Seguidamente, cambiamos esa versión por la de nuestro iPhone

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente

9º) Vamos a Archivo--> Guardar y cerramos la ventana de texto.

Tutorial: Ejecutar aplicaciones que requieren una versión de software más reciente


Para los 3 últimos pasos, creo que ya no hacen falta capturas:

10º) Ahora, maximizamos la ventana del WinRar, seleccionamos el archivo 'info.plist' (el original, puesto que el modificado lo tenemos en el escritorio) y lo eliminamos. Si nos pide confirmar, aceptamos.

11º) Arrastramos el archivo 'info.plist' que hemos modificado, y lo colocamos dentro de la ventana de WinRar. Cerramos la ventana WinRar

12º) Para terminar, hacemos doble 'click' sobre el archivo '.ipa', con lo que se abrirá iTunes y nos preguntará si queremos sustituir la aplicación. Aceptamos y sincronizamos el iPhone.

Espero que os sea útil.
Un saludo,


Tratos OK: deltaone, jahj, Volandius, bigganda, celit, warinice, pluvio, m3406vy, toyoti143


TUTORIAL: Cómo ejecutar en el iPhone aplicaciones que requieren un software más actualizado.
 #3
Escrito   0  0  
Sí que lo es, si

gracias

Soy de Madrid
 #4
Escrito   0  0  
Hay una manera mucho mas facil para evitar tener que hacerlo aplicacion por aplicacion y es cambiandole al iPhone la identificacion del sistema operativo que es.
La aplicacion se llama FWChanger y esta disponible en Cydia. La descargamos, la instalamos y la abrimos. Aqui debemos poner en el campo firmware:
2.2.1
y en el campo build:
5H11

Con esto, para el iPhone tendremos el firmware 2.2.1 y para todas las aplicaciones, tambien.
De esta forma puede que nos ahorremos el actualizar por alguna aplicacion.

Salu2

Movil actual: Nexus 4
 #5
Escrito   0  0  
75950282 y schumy, cojonudo saber esto!!


El Bierzo
 #6
Escrito   0  0  
gracias por el tuto!
 #7
Escrito   0  0  
y haciendo eso ya se puede usar las aplicaciones q requieren una aplicacion mas nueva q la 2.2? incluso los juegos q m pide la version 2.21. y haciendo esto s m actualizara el iphone, mas q nada es q lo tengo libre y m da miedo q se bloquee. gracias
 #8
Escrito   0  0  
Haciendo eso engañas al telefono para que crea que es una 2.2.1 cuando realmente es una 2.2. No es en si una actualizacion de software, es simplemente un engaño.
Ni pierdes la liberacion ni nada por el estilo porque sigues en 2.2.

Salu2

Movil actual: Nexus 4
 #9
Escrito   0  0  
En mi caso cojo una IPA de la Appstore que es Gratis desde el directorio donde la ha dejado C:\Documents and Settings\nooficial\Mis documentos\Mi música\iTunes 1\Mobile Applications, pero el fichero Info.plist no esta en formato legible al abrilo con el WordpAd (en el resto de ipas si funciona correctamente y es legible) ?????

No se puede con las IPAs que instala automaticamente itunes ???




"bplist00ß _CFBundleVersion_CFBundleIdentifier]NSMainNibFile_CFBundleExecutableYDTSDKName_MinimumOSVersion_CFBundleDevelopmentRegion^DTPlatformName_CFBundleInfoDictionaryVersion_CFBundleResourceSpecification_CFBundleDisplayName_CFBundleSignature_
 #10
Escrito   0  0  
Esos ficheros estan en binario. Hay que usar una utilidad llamada Pledit para hacerlos legibles.

Salu2

Movil actual: Nexus 4
Volver a Apple